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Exercise 1.1: Getting Started with BusinessObjects

Learning Objective: Learn to login, navigate, configure, and review on-line documentation. 

Estimated Time: 20 minutes

Scenario: Refresher exercise to get reacquainted with BusinessObjects.

Directions:

1. To Login:

· Go to Start|Programs, select BusinessObjects 5.1.

· Select BusinessObjects from the next menu.  

· Use the User Name and password your instructor gives you.   

2. How many chances do you get to enter your login details correctly? ___________________________________________________

      Three 

3. The New Report Wizard starts by default.  Select "Cancel".

4. Next, let's review some of the menus.

5. Ensure the Standard, Formatting, and Report toolbars, at least, are selected.  Where do you go to do that? _______________________________________________________ View|Toolbars or right-click the menu area for the popup menu.
6. Where do you go to login again?  Where can you change your password? Do NOT change your password. ________________________________________________________Tools|Login As to login again.  Tool|Change Password to change password
7. Make any changes you like to customize the way the New Report Wizard runs. (HINT: Tools>Options>New Document)

· In the Report Layout section you can:

· Prompt User for report layout

· Select a Template

· Use a Default Template

· Use a Standard Report

· In the Data Access section you can:

· Prompt User to choose a universe or personnel files

· Select a Universe

· Use the Default Universe

· Use a Different Data Provider
8. Use the New button or File>New to test your changes

9. Open any BusinessObjects document on your hard drive. 
10. Where can you find and change the file location of BusinessObjects files? Do not change the default settings.

___________________________________________________ Tools|Options|File Locations
11. Next, let's review the on-line BusinessObjects User's Guide.

12. Using the User's Guide answer the following questions:

What is a break?

 _________________________________________
     

 
      It breaks up the data in a table or crosstab by

      grouping the data according to a selected value.

                 What is a free-standing cell?

       ________________________________

  A free-standing cell is a single cell that is not attached to any      

      other report component and can be moved and formatted 

      individually.  For example, the cell that contains a report's title.

     What is a data provider?    

       ____________________________________

     Mechanism that retrieves data for reports. The following types

     of data providers are available: queries on universes, stored

procedures, free-hand SQL scripts, personal data files, etc.
13. Review the Getting Started with BusinessObjects on-line tutorial, just to see what is available.

14. Take one of the modules of the Quick Tour multimedia guide.

15. When you're finished exit the product.

Exercise 2.1: Building a Basic Query

Learning Objective: Build a simple query.

Estimated Time: 10 minutes

Scenario: You need a report on total population of all bases on the database.  

Directions:
1. Login to BusinessObjects. The "New Report Wizard" will automatically start. 

2. If you are already logged in, select File|New.

3. Select "Begin", "Next", "HR Reporting" universe, and "Finish".

4. You are now at the Query Panel.

5. In the Class and Objects panel:

· Click to open the Employee Basic Information class.

· Put CCPO ID, CCPO ID Clear Text, and Gender in the Results panel. (Highlight and press Enter, drag and drop, or double-click).

· Open the Position Data class.  Put Pay Plan in the Results panel

· Open the Position - Employee class. Put Total Employees measure object in the Results panel.

6. Press the Run Button and review your report.

7. Next , we’ll modify the report to select only certain CCPO Ids and encumbered positions only.  

8. Select the Edit Data Provider button to return to the Query panel. (You could also select "Data" and "Edit Data Provider" from the menu.)

9. Apply a Simple Condition to the CCPO ID object.

· Right-click the object in the Results Panel.

· Choose Apply Simple Condition

· Select several non-contiguous CCPO Ids. (HINT: Ctrl-click)  Click OK.

· Notice the condition appears automatically in the Conditions panel. 

10. Next, apply a predefined condition to limit the report to Encumbered Positions only.

· Change the Classes and Objects panel to Predefined Conditions by selecting the filter radio button.

· Open the Position – Employee class.

· Select the EncumberedPositions predefined condition.

· Ensure this condition appears in the Conditions panel.

11. Now, rerun the query.

12. Next, let's copy this table. 

· Click inside the table and a hatched gray border appears around the table.

· Move the cursor over the table border.  When the cursor changes to the move cursor (crossed arrows), hold down the left mouse button and drag the cursor below the table. (Or to any white area in the document).

· Hold down the Ctrl key.  The cursor changes to the copy cursor.

· Release the mouse button.   The table is copied to the new location. Copy the table as many times as you like.

13. Return to the Query Panel 

14. Delete the simple condition you created by right-clicking it and selecting Delete. 

15. Create two new Simple conditions

· CCPO Id equal to any one CCPO.

· Gender equal to any one gender.

· Click OK and rerun the query.

16. If needed, move the tables so they don't overlap.

17. Make any formatting changes you like.

18.  Save the document as Exercise2-1.rep to your hard drive.

Exercise 2.2: More Basic Queries

Learning Objective: Build a simple query.  

Estimated Time: 10 minutes

Scenario: You need a report on Wright-Patterson AFB. (CCPO = 9X) with only certain pay plans.

Directions:
1. Login to BusinessObjects or if you are already logged into BusinessObjects select File|New.  

2. The "New Report Wizard" will automatically start. Select "Begin", "Next", "HR Reporting" universe, and "Finish".

3. You are now at the Query Panel.

4. In the Class and Objects panel:

· Click to open the Employee Basic Information class. Put Gender in the Results panel.

· From the Position Data class get Pay Plan.

· From the Position – Employee class get Total Employees.

5. From the Predefined Conditions panel:

· Open the Position – Employee class and select EncumberedPositions.

6. Go back to the Classes and Objects panel.  Now we will create a Complex Condition to select only Wright-Patterson AFB. (CCPO = 9X)

· Drag the CCPO ID object to the Conditions area.

· Notice BusinessObjects automatically starts building a condition for you and the Classes and Objects panel turns into the Operators panel.

· Select Equal To, Show List of Values, and 9X.

7. Before we run this report we want to be sure it will get the data we want.

· Use the View button to view the data that will be returned by this query.

· We notice there are many pay plans at W-P that we don’t want in our report. We want only GS, WG, WL, and WS in our report.

8. Pay Plan is one of the objects in the Results panel. 

· Therefore, you can create a Simple Condition or, if you choose, create a complex condition by adding Pay Play to your Conditions panel from the Classes and Objects panel.  

· Using either method, select only Pay Plans GS, WG, WL, WS and run the query.  Review the report.

9. Choose the Edit Data Provider button.

10. From the Position Data class, add Grade or Level Clear Text to the Results panel.

11. Add a condition to select only grades 7 through 11 and rerun the query.

12. Save the document as Exercise2-2.rep to your hard drive.

Exercise 2.3: More Basic Queries 
Learning Objective: To work with more parts of the Query Panel.

Estimated Time: 10 minutes

Scenario:   You are developing a report and want to use some of the options in the Query Panel to assist you.

Directions:
1. Build a new report to show:

·  CCPO ID, Gender, and Name Employee from Employee Basic Information.

· Grade or Level Clear Text, Occupational Series, Office Symbol, and Pay Plan from Position Data. 

· Select encumbered positions.

2. Rearrange the objects in the Results panel to be in the order you want them on your report.

3. Select encumbered records only.

4. Select the Options button on the lower left side of the Query panel.

· Change the Partial Results to 20 Rows.

· Press OK and Run the report.

· Return to the Query panel and press the Options button again.

· Set the Partial Results to Default and select Do Not Retrieve Data.

· Press OK and Run the report

· Press the Refresh button to populate the report with data.

· Return to the Query panel and press the Options button again.

· Uncheck Do Not Retrieve Data.

5. Select the View button on the Query Panel.    

· Review the Results tab.

· You will see the raw data returned by the data provider.

· Sometimes you will see #EMPTY in a field.  The report will run correctly in spite of this message.

· Press the Export button.  Note you can export the data to different file formats.  We will do this later in the course. Press Cancel to return to the previous screen.

· Press the Refresh button to refresh the data provider.

· The Options button on the Results tab screen is the same as the Options button on the Query Panel.  

· Review the Definition tab.

· It displays information about the data provider or the variable selected in the Data Providers box.  

· To rename the data provide:

· Select it in the Data Providers panel.

· Type the new name, Exercise2.3, in the name text box.

· You can do a several other actions in this tab such as change the universe and set  the date and time for automatic refreshes.

· Select an object in the Data Providers box and the object’s name, type, qualification, and values will be displayed. 

· This is also where you to link dimensions belonging to different data providers.

6. Try pressing the ESC button before the report has a chance to finish running.  Note the options in the window that comes up.

· If you select "Stop the execution and keep the partial results" note the flashing alert in the status line reminding you the report is displaying only partial results.
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Exercise 3.1: Basic Editing 
Learning Objective: Retrieve an existing corporate document; refresh data; navigate, print preview; and save a report to your hard drive. Use the Undo button.

Estimated Time: 15 minutes

Scenario:  Someone in your CPF has built and published a document named GunterEmplist.rep.  You need to review and modify it to ensure it satisfies your requirements.

Directions:

1. If you have just logged in and the New Report Wizard starts, cancel it.

2. Retrieve the GunterEmplist.rep report from the corporate storage area.     (File>Retrieve>Corporate Documents). This file may already be on your hard drive. If so, you will be asked if it is ok to replace it; select Yes.

3. When was the last time this document was refreshed? ____________________________________________________    See bottom status bar
4. How can you ensure it contains the most recent data?                  ____________________________________________________  Refresh button
5. Activate the Report Manager panel, if it is not already displayed.  What does the Data tab of the Report Manager tell you? ___________________________________________________   Variables and Formulas in the report
6. Close the Report Manager so you can see more of the report.

7. There are at least three ways you can close the Report Manager. What are they? _____________________________________________________

Select View>Report Manager, or Report Manager button, or 'x' on top right of panel 

8. Add the Alignment and Borders toolbars to your top toolbar area.

9. Review the first few pages of the report.                                            (HINT: Short cuts to go to the bottom and return to the top of the report are ctrl-home, ctrl-end, page down, page up, ctrl-page down, ctrl-page up.)

10. How many pages are in this report? (HINT: Print Preview)  ________________   DO NOT PRINT.
11. Duplicate report and rename the tab to whatever you like.

· Right-clicking the report tab can do both. 

· Rename can also be done by double-clicking the report tab.

12. Modify column widths to fit on letter size paper in portrait. (HINT: You may have to delete columns to get it to fit)

· Use both the manual and automatic methods. 

· Use the Undo button if you make a mistake. 

· Both Print Preview and View>Page Layout are helpful in determining what your report will look like printed.

· Now how many pages are there? ______________

13. Experiment with changing row sizes.

14. Change column heading to anything you like.

15. Move and swap columns to make the report easier to use.

16. Modify the alignment, font, background, and border colors anyway you like. Use the Undo button if you make a mistake.

17. Save document as Exercise2-1.rep to your hard drive.

18. What folder is your document saved in? _________________________  UserDocs
19. How many reports are in this document? 

      __________________

20. What file extension do BusinessObjects documents have? ______________________ .rep
Exercise 3.2: More Basic Editing

Learning Objective: Modify an existing corporate document by adjusting columns and rows, inserting columns and rows, formatting report title and column headings, etc.  Use the Undo button.

Estimated Time: 15 minutes

Scenario: You want to use a corporate document someone else created but need to modify it to suite your needs.

Directions:
1. If you have just logged in and the New Report Wizard starts, cancel it.

2. Retrieve the GunterEmplist5A.rep report from the corporate storage area. (File>Retrieve>Corporate Documents).

3. How many pages are in this report? _________________

4. Refresh the data to ensure this is the most current report.

5. Modify column widths of the report to fit on letter size paper in portrait or landscape (your choice). Use both the manual and automatic methods. Use the Undo button if you make a mistake.

· Both Print Preview and View>Page Layout are helpful in determining what your report will look like printed.

6. Now how many pages are in this report? ________________

7. Modify the row heights of all rows.  Use both the manual and automatic methods.  

8. Use the AutoFit feature to resize the columns. (HINT: Format>Cell Height and Width)

9. Change the column headings and report title to whatever you prefer.

10. Ensure the column heading will repeat on every page when printed.

11. Use the Font Color, Background Color, and Border Color buttons to modify the color of the report title and headings.

12.  Expand the left side of the report title cell to the left side of the table.  Enter any title you like and left justify the report title text.

13. Add the Structure toolbar to your top menus.

14. Double-space your report by adding a row after each line of data as follows:

· Select the data area of the Employee Name column

· Use the Structure toolbar and either of the insert row options.

· (You can also add rows and columns with the Insert Row/Column button which is the 5th from the left on the Report toolbar) 

15. Insert a column on the right side of the report and name it Remarks.

16. Insert a freestanding cell in the white space outside the table. Enter your name in the cell.  

17. Move the cell and the whole table, if needed, to display the report most effectively.

18.  "Freeze" the column headings and the left most column so you can scroll the report and still view the headings and left most column.

19. Undo the double spacing without using the Undo button. 

· Bring the cursor to the left of any blank line in the table to the "black arrow".  Click to select every blank line.  Use the Delete button on the tool bar to delete every blank line.  

20. Next, let's copy this table. 

· Delete all but three columns in the current table.

· Click inside the table and a hatched gray border appears around the table.

· Move the cursor over the table border.  When the cursor changes to the move cursor (crossed arrows), hold down the left mouse button and drag the cursor to the right of the current the table. (Or to any white area in the document).

· Hold down the Ctrl key.  The cursor changes to the copy cursor.

· Release the mouse button.   The table is copied to the new location. Copy the table as many times as you like.

21. Insert a cell to the right of the title and enter your name.

22. Modify the borders of this cell.  There are four ways to do this.  Select the cell then:

· Use the Borders Button.

· Use the Borders toolbar.

· Right-click the new cell, select Format Cell and choose the Borders tab.

· From the top menu, select Format>Cell and the Borders tab. The last two methods give you the most options.   Use one of these methods.

23. Experiment changing the borders of the new cell.  Click outside the cell to see the result. 

24. Align the new cell and the report title any way you want.

25. Use any of the other editing techniques you've learned.

26. Save document as Exercise3-2.rep to your hard drive.

Exercise 4.1: Simple Calculations, Sorts, Filters, and Breaks
Learning Objective: Modify an existing user document by moving, swapping columns, resorting, and adding simple calculations. 

Estimated Time: 15 minutes

Scenario:  To make an existing document more useful to you and your customer you need to resort, add some calculations, and make format changes.

Directions:
1. Retrieve the GunterSimpleCalc.rep report from the corporate storage area. (File|Retrieve>Corporate Documents).

2. Make SSAN the second column.  

3. Ensure Pay Plan, Occupational Series, and Grade columns are in this order.

4. Make any other column moves and swaps you like.

5. Use View > Page Layout to see how the report would print.  Ensure you can fit the report on letter size paper in portrait orientation. 

6. Duplicate the report and rename the new tab Calculations.  Do the calculations in this report.

7. Apply a Count and a Count All to the Pay Plan column.  What is the difference?  ___________________________________________

Count counts distinct data, Count All counts all rows.

8. How many different Pay Plans are there at this base? _________________

9. How many different Pas Codes (Org Components Clt 2) are there at this base? _________________

10. What is the average grade for this base? ___________________________________
11. Apply a Count All to the name column and remove the Count All from the Pay Plan column.

12. What base is this report for? _________________________________________  
    5A, Goodfellow.  Use Edit Data Provider button to check      conditions panel

13. Add a break on pay plan.

· The calculations you've add do not display at each break, just at the bottom of the report.  If you add calculations after the adding a break they will display at each break.  Try it.

· Format the break any way you wish.  

· Remove the break.

14. How is the report sorted by default? ____________________

By the first column, then the second, etc.

15. What are three types of sorts? __________________________________________________

Ascending, Descending, Custom

16. Resort the report in any of the above ways using any columns that you choose.

· Experiment with ascending, descending, and custom sorts.
17. From where can you manage your sort order? ________________________

Format|Sorts

18. Go there and experiment with managing your sorts.

19. Select the Pay Plan column and custom sort it with Wage board employees first, General Schedule next, and the rest (if any) in any order you like. 

· If the report does not sort as you expect, you may have to delete conflicting sorts.

20. Save document as Exercise4-1.rep to your hard drive.

Exercise 4.2: More Simple Calculations, Sorts, Filters and Breaks

Learning Objective: Retrieve and modify an existing document corporate document; insert and format cells; resort; filter, and simple calculations.

Estimated Time: 15 minutes

Scenario:  You have a report that has too much information so you use filtering to limit it.

Directions:
1. Retrieve the GunterVacancy5A.rep vacancy report from the corporate storage area. 

2. Ensure it contains the most recent data. 

3. Duplicate this report and change the tab name to whatever you like.

4. Make your modifications to the new report.

5. Center align the data all the columns but leave the headings left justified.

6. Filter in only the 3## series positions and only grade 9 and above.

7. What is total number of vacancies that now?

8. Filter the report to see only WG/WL/WS pay plans. How many vacant wage positions are there?  ________________________________ (HINT: You will have to remove other filters first.)

9. Experiment adding and deleting filters using both the toolbar button and using the Format>Filters dialog box.

10. Remove all filters.

11. Insert a count of all positions. How many total vacant positions are there?   _______________

12. Insert a count of different positions. How many different position titles are there?  _______________

13. Custom sort so all the supervisory positions are at the top of the report. 

14. Change the color of both the report title text and background.

15. Insert a cell to the right of the title and enter a name and poc for this report. Format this cell any way you like.

16. Change the report title as follows:

· Include the word “Goodfellow AFB”. 

· Expand the cell to the left margin, left justify, bold, and italicize the title.

· Remove the top and right borders and bold the remaining borders. 

17. The CCPO column is no longer needed, delete it.

18.  Make CPCN the first column.

19. Remove any sorts.

20. Sort on Grade so the highest grades show at the top of the report.

21. Break based on Position Title.

22. Save document as Exercise4-2.rep to your hard drive.

Exercise 4.3: More Simple Calculations, Sorts, Filters and Breaks

Learning Objective: Build and modify a simple report. 

Estimated Time: 15 minutes

Scenario:  You've received a request for a Vacancy Report for Goodfellow AFB.  

Directions: 

1. Build a report to include the following data: 

· From Position Data class; CCPN, Grade or Level Clear Text, Occupation Series, Pay Plan,  Sequence Number, Position Title,  Position Description Number.

· From Employee Basic Information; CCPO ID. 

· Rearrange the objects in the Result panel so the columns of your report will be the way you want them.

2. Select Goodfellow AFB (CCPO = 5A) and unencumbered positions.

3. Run report.

4. Sort in ascending order by Position Title.

5. Move CCPN to first column if it is not already.

6. Change column headings whatever you prefer.

7. Center each column heading.

8. Change report title to "GOODFELLOW VACANT POSITIONS".

9. Delete the CCPO ID column.

10. How many pages is this report? ______________

11. How many vacancies are there? ______________

12. Insert a break on Grade.

13. Format break so Grade is centered across break.

14. Add to the query a condition to select only the 17## Occupational Series and rerun the report. 

· If you don't find 17##, run report for all unencumbered positions to find which unencumbered occupational series exist at this base.

· Then modify condition for any occupational series found.

15. Make any other formatting changes you like.

16. Save document as Exercise4-3.rep to your hard drive.

Exercise 4.4: More Simple Calculations, Sorts, Filters and Breaks
Learning Objective: More experience working with filters.

Estimated Time: 10 minutes

Scenario: You will create one large report, thus pulling the data a single time, then use filtering to generate many reports.

Directions:
1. Build a new report using:

· CCPO ID, Grade or Level Clear Text, Occ Series, Office Symbol, Pay Plan, Position Title, Gender, and Total Employees. 

· Select Encumbered Positions and run the query.

2. Clean up the columns, swapping where needed.

3. Rename the report to No Filters.

4. Duplicate the report, and rename it to Filter on CCPO.

· Use the Filter On CCPO report to the following steps.

5. Click on the CCPO ID column and select the Filter button.

· Select one of the CCPO Ids to be filtered (5A for example).  

· Note the report now only shows data for that ID.  The other data is still available, just not displayed.

6. To select a different value for the filter, right-click in the filtered column, select Format Filters.  Select a different ID (6Z for example).  Click Apply and Ok. 

· This was just another way to work with simple filters.  You could have clicked the Filter button twice, once to toggled the current filter off, a second time to select a new object to filter on. 

7. Add the following filters:

· GS on the Pay Plan

· 0201 on the Occ Series

8. Right-click anywhere in the white space of the report outside of the table and select the Format Filters option.  

· In the Filters On panel on the left you can see any and all filters currently applied to the block.  If the Table folder is not opened, click the plus sign (+) to open it.  As you click on each filter, the Values panel on the right will display the object that is filtered into your report.

· You can modify your filters from here. Try it.  For Example, change the CCPO filter to something else.  Click Apply and Ok.

·  Exit the Filters dialog box when done.

9.  Duplicate this report, call it More Filters.

· Use the More Filters report to the following steps.  

10. Copy the table to right below its current position (hold CTRL just before releasing the mouse button).

11. On this new table change the value filtered in the Occ Series to 0301.  

12. Right-click anywhere in the white space of the report outside of the two tables, select Format Filters.  The Filters On panel shows filters applied to both tables in this report.  

13. Click on Global, and then Add a filter.  Select Gender, choose F.  

14. Click Apply and OK.  Now both tables have been filtered to show only Female, regardless of what other filters each has on other objects.

15. Save document as Exercise4-4.rep to your hard drive.

Exercise 5.1: Complex Filtering and Ranking
Learning Objective: In an earlier section you learned about filtering data.  Now you will learn a more advanced form of filtering that allows you to set conditions.

Estimated Time: 15 minutes

Scenario:  We want to see all Occupational Series that have more than a certain number of employees.  We could apply conditions on the original query to accomplish this, but then we would be limited to that data only unless we rerun the query.  In the following exercise we create a complex filter for all Occupational Series with greater than 4 employees. You may need to use a different number that will work for your specific report.  

Directions:
1. Build a new report using:

· CCPO ID, Occupational Series, and Total Employees. 

· Select CCPO ID 5A and encumbered positions and run the query.

2. Format the report any way you wish. 

3. Rename the report tab Complex Filter. 

4. Click anywhere inside the block.  Select Format>Filters from the menu.  This brings up the familiar Filters window.

5. In the Filters On panel click the block rather than Global. 

6. Click on Add.  Select Total Employees from the list and OK. 

7.  Notice the list of values. 

· We could click on contiguous values there, but that would not be creating a complex filter. 

· And, if the number of total employees in an Occ Series changed between reporting periods, the report would not be correct the next time it was run. 

· Therefore, we need to create a complex filter using a formula. Review the numbers in the list of values to determine the number of employees to filter for.  You don’t want to choose a number larger than the maximum number of employees in any Occ Series. 

8. Define a filter.  

· Click on Define.  The Filter Editor comes up.

· By selecting items in the frames below the Formula box we can build our complex filter. 

· Double-click on Total Employees. 

· Double-click on the Greater Than symbol over in the Operators frame. 

·  Enter the number you want to filter for (In my example, I would enter 4).  

· Click OK.  

9. Notice something different about the Filter on Total Employees—it has an asterisk by it, which means it has a complex formula. 

10.  Click OK to close the window.

11. Review your report to ensure it is correct.

12. Modify the query to select a different CCPO ID (for example 9X) and run the report again. 

13.  Review the report to see the complex filter's effect.

Exercise 5.2: More Complex Filtering and Ranking
Learning Objective: Manipulate the data in a report by filtering in order to analyze it better.  Use ranking, sorting and/or filtering to obtain your result.

Estimated Time: 10 minutes

Scenario: Wright-Patterson AFB (CCPO ID 9X) needs a report to analyze health plan membership by gender. 

Directions:
1. Build and run a report with Health Plan Clear Text (in the Benefits class), Gender, and Total Employees for W-P AFB encumbered positions.

2. Use ranking to determine the top 3 Health plans for males and the top 3 for females.  (HINT: Two separate reports with simple filters on gender)

· Display percentages and subtotals. 

· Record below the total number, percentages and plan names of the three plans with the most members by gender. 

Health Plan

Total number                Total %

Males ____________________________________________

Males ____________________________________________

Males ____________________________________________

Females __________________________________________

Females __________________________________________

Females __________________________________________

3. Use sorting, ranking, or filtering to answer the following questions.

What plans (if any) have more than 1000 males or females? _________________________

How many males total in the plans of 500 or more males? _________________

How many females total in the plans of 500 or more females? ________________

How many plans have less than 5 males?  _______ 

How many plans have less than 5 females? _________

4. Save document as Exercise5-2.rep to your hard drive.

Exercise 5.3: More Complex Filtering and Ranking
Learning Objective: Manipulate data in a report by filtering to analyze it better.

Estimated Time: 15 minutes

Scenario:  We need to provide an analysis of the high-grade positions by gender and Occ Series.  You will need to provide specific totals at the end of the exercise. Create a report of GS and GM employees grade 13 and above.

Directions:
1. Build a report to show:

· Position Title, Pay Plan, Occupational Series, Grade or Level Clear Text, Office Symbol, Total Employees, and Gender.

· Select encumbered, GS and GM employees, and grade greater or equal to 13. 

2. Run Report.

3. Rename report to "All".

4. Duplicate report to another tab and rename "Males".

5. Duplicate report to another tab and rename "Females".

6. In Males report, filter in Males. Insert a Sum at bottom.  

7. Use short cut key to go to the bottom of the report to view total.  How many males does the report show? _______________________

8. In Females report, filter in Females. Insert a Sum at bottom.  

9. Use short cut key to go to the bottom of the report to view total.  How many females does the report show? ______________________

10. In the All employees report, insert a Sum at bottom.

11. Use short cut key to go to the bottom of the report to view total.  What is the total number of GS/GM employees? ___________________

12. Save document as Exercise5-3.rep to your hard drive.

Now let's gather some more information from our reports. You may want to use Simple or Complex Filters and Ranking to assist you in answering these questions.

Total Males in grade 15: _______________.

Total Males in Occ Series 861

(Remember to remove the Grade filter):___________.

Total Males in GM pay plan 

(Remember to remove the Occ Series filter): ____________.

Total Females in grade 15: _______________.

Total Females in Occ Series 861

(Remember to remove the Grade filter):_________.

Total Females in GM pay plan

(Remember to remove the Occ Series filter): ____________.

Which Occ Series has the most Female GS 15s: ________________. (use Break)

Which Occ Series with the next most Female GS 15s: ____________.

How many total male and female employees are GM: ________________.
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Exercise 6.1: Crosstabs

Learning Objective: Retrieve an existing document corporate document and display it as a table and crosstab.

Estimated Time: 15 minutes

Scenario:  You want to find the best way to present your data so you experiment with various presentation styles.

Directions:
1. Retrieve GunterCrosstabEx1.rep.

2. The column heading “Sex” is the old name of the object now named “Gender”.  If AFPC renames an object, when you refresh the data in the document the new object name will replace the old.  Refresh now.

3. Give this report and title you like.

4. Rename the report tab "Table".

5. Duplicate the report two times and rename the report tabs "Fin Table" and "Crosstab".

6. Click on the “Table” report tab. 

7. Click on the "Insert Table" button to insert a new table within this same report.

· Move to where you want to insert the table and the mouse pointer will change.  

· Now click and the Table Wizard will start.  Choose "Use existing data from the document" and click "Begin". 

· Select Gender and Total Employees and click "Finish". 

· A new table appears.

8. Go to the "Fin Table" report. 

· Click anywhere in the table to select it.  Using the "Rotate Table" button turn it into a financial style table.

9. Go to the "Crosstab" report.

· Ensure the columns are in this order: Gender, PATCOB, and Total Employees.

· Select the data area of the Gender column and drag it to the top right corner of the table over the Total Employees column heading.  

· Look for the pointer to change to a crosstab symbol

· Look for the status bar to confirm that you can drop to create a crosstab. 

· Release and a crosstab is created.

10. Next, we will use the Crosstab Wizard to create the same crosstab as above.

· Click the Insert Crosstab button on the Report Toolbar.

· Move to where you want to insert the crosstab and the mouse pointer will change. 

· Now click and the Crosstab Wizard will start.  Choose "Use existing data from the document" and click "Begin".

·  Select PATCOB, Gender, Total Employees, "Next" and "Finish".

· If the report doesn't look like you want swap the row and column headers.

11. Select one of the Crosstabs.

· Under Format Dropdown Menu, select “Breaks”.

· From the “Breaks” Popup Window, Select the “Down” Edge Tab.

· Click on “Add”  Button, click “Variable Check Box” for “PATCOB” & Click “OK”.

· Some Default Options are already selected.

· Select  “Break Header”. 

· Unlike applying a “Break” to a Table, when applying a “Break” to a Crosstab, you must manually add a “Header” once you apply this option.

· Click OK and the Crosstab is now viewable with Breaks.

12. To add a label in the body of the crosstab, click in the blank cell under the “F” bringing up a “Yellow Cell” throughout your document.   Type “Gender Total” and press Enter. 

· This will auto-populate all the yellow cells within the entire document at this point.

13. To add a label for the rows, click in the blank cell above the Row Heading “A” again bringing up a “Yellow Cell” throughout your document.  Type in “PATCOB” and press Enter. 

· This will auto-populate all the yellow cells within the entire document at this point.

14. Click in the row headings underneath the PATCOB label you just entered.

15. Choose custom sort and sort the rows to spell PATCOB.

16. Click anywhere within the Crosstab.

17. Under Format Dropdown Menu, Select “Breaks”.

18. Experiment with other options and “Apply” to see the effects.

19. Save document to your hard drive as Exercise6-1.rep.

Exercise 6.2: More Crosstabs

Learning Objective: More practice creating crosstabs.

Estimated Time: 10 minutes

Scenario:  You have been asked to provide data analysis on gender as it relates to grade, occupational series, and pay plan of employees for an EEO hearing. This analysis is for GS, GM, WG, WL, and WS employees only. 

Directions:
1. Include in your report: Gender, Grade or Level Clear Text, Pay Plan, Occupational Series, and Total Employees. 

2. Select any CCPO you like (you can use all if you like).  Select encumbered positions and only the Pay Plans indicated above.

3. Insert 3 blank reports and name them as you like.

4. Create the following three crosstabs, each on a separate report using the insert crosstab button.

· First Report: Create a crosstab to show Gender, Grade or Level Clear Text, and Total Employees.  

· Ensure Gender is the column header.

· Add a SUM to this report.

· Second Report: Create a crosstab to show Gender, Pay Plan, and Total Employees.  Ensure Gender is the column header.

· Add a SUM to this report.

· Third Report: Create a crosstab to show Gender, Occ Series, and Total Employees.  Ensure Gender is the column header.

· Add a SUM to this report.

5. Save document to your hard drive as Exercise6-2.rep. We'll use this report again.

What conclusions, if any, can you reach about the distribution of employees by gender among pay plans, grades, and occupational series?

________________________________________________________________ 

This page deliberately left blank.

Exercise 7.1: Creating a Chart From a Table & the Chart Wizard

Learning Objective: Practice with charting data.

Estimated Time:  10 minutes

Scenario: Create a chart using an existing table and from the Chart Wizard.

Directions:

1. Retrieve GunterChartEx1.rep and refresh the data.

2. Rename the report tab "Chart".

3. Right-click the Table to get the pop-up menu.

4. Select "Turn to Chart".

· Select the 3-D Column with X, Y, and Z gridlines.

5. Make any needed changes to move or enlarge the chart.

6. Right-click on the Chart.

7. Select “Format Chart”.

· Select the “Pivot” tab.

· Drag Gender to the “Z-Axis” Folder.

· Click “OK” and see how the chart has changed.

8. Now we will use the Wizard to create a new chart.

9. Right-click on the Chart Report Tab and select “Insert Report” to get a blank report screen.

10. Click the "Insert Chart" button on the Report Toolbar.

· Place the cursor where you want to insert the chart.

· The mouse pointer will change to the Insert Chart cursor.  

· Now click and the Chart Wizard will start.

· Choose "Use existing data from the document" and click "Begin".

· Select PATCOB, Gender, and Total Employees, click "Next".

· Select 3-D Column with X, Y, and Z gridlines and "Finish".

11. Make any needed changes to move or enlarge the chart.

12. Save document to your hard drive as Exercise7-1.rep.

Exercise 7.2: Creating and Formatting Crosstabs and 3D Bar Charts

Learning Objective: To create a crosstab from a table and a chart from a crosstab.

Estimated Time: 15 minutes

Scenario:   We need a report to analyze encumbered positions by grade and pay plan using tables, crosstabs, and charts for Peterson AFB CO, CCPO ID 6X.

Directions:

1. Build a report and include Total Positions (Position Data class), Pay Plan, and Grade or Level Clear Text.

2. Select encumbered positions, Pay Plans GM, GS, WS, WL, and WG for CCPO ID 6X. (HINT:  If you create a complex condition use "In List" operator for Pay Plans.)

3. Run report.

4. Ensure the Total Positions column is the last column on the right side of the table.   

5. Make any formatting changes you want.

6. Turn the table into a crosstab with Pay Plan the column header. 

· To do this, select Pay Plan data area, drag yellow cell over Total Positions column heading until crosstab symbol appears, and release.

7. Select the crosstab and insert SUM.

8. Duplicate the report. Name one Crosstab and the other 3D chart.

9. In the 3D chart report:

· Turn the crosstab into 3D column chart with X,Y, and Z gridlines using the pop-up menu (right-click). 

10. Right-click chart to insert legend and add a title.  

11. Increase table size and move table, if needed, and do any other formatting you choose.

12. Ensure Total Positions axis and Grade axis are formatted to read normally.

13. Insert cells with Total Positions, Pay Plan, and  Grade to label each axis.

14. These cells can only be inserted OUTSIDE the chart box.

15. Experiment with other formatting options such as colors, shading, etc.

16. Save document to your hard drive as Exercise7-2.rep.

Exercise 7.3: Creating and Formatting 3D Area Charts

Learning Objective: Practice charting data.

Estimated Time: 15 minutes

Scenario: Build a report to analyze employee population by pay plan for all bases.   Find a visual display of the data that will best present your data and be easy to read.

Directions:

1. Build a query that includes CCPO ID, Pay Plan, and Total Employees. 

2. Select only pay plans GM, WG, WS, and WL and encumbered positions.

3. Run report.

4. Convert the table into a crosstab with Pay Plan as the column header.

5. Convert the crosstab to a 3D Area chart.  

· Select the crosstab, right-click to display the pop-up menu, select Turn to Chart.

· Select 3D Area with X,Y, and Z gridlines and click OK.

6. Resize the chart to see all the axis labels.

7. Some of the data may be hidden behind some data series. Resort the data series to make it easier to read.

· Select the Pay Plan labels.

· Select the Custom Sort from the Toolbar.

· Move the Pay Plans up or down to resort them to make the chart easier to read.

8. Select the chart.  

9. From the Format menu choose Chart. 

10. From the Series tab, change the elevation, rotation, chart depth, and gap width to get a different view.

· Use the Help button to determine the range of values available for each of these options.

11. Make any other changes you want.

12. Save document as Exercise7-3.rep.

Exercise 7.4: Creating and Formatting Pie Charts

Learning Objective: Practice charting data.

Estimated Time: 15 minutes

Scenario: Build a report to analyze employee population by race and gender for Goodfellow AFB.  A visual display of the data will best present your data.

Directions:

1. Create a query that includes Race National Origin Clear Text (Employee Basic Information class), Gender, and Total Employees.

2. Select only Goodfellow AFB (CCPO 5A) and encumbered positions.

3. Run report. 

4. Use the Insert Chart button to experiment with the different types of charts.

· After you have experimented with chart types, select a pie chart with data labels to represent the data in the table.  

· Insert a title, legend, and resize chart if necessary.

· Filter female and male White, not of Hispanic Origin employee out of the pie chart.

5. Make any other format changes you like.

6. Save document as Exercise7-4.rep.

Exercise 7.5: Adding Charts to Crosstab Reports

Learning Objective: Practice adding charts to preexisting reports.

Estimated Time: 10 minutes

Scenario: Add two charts to better display the data.

Directions:

1. Build a report that includes:

· Gender, Grade, and Total Employees.

· Select encumbered positions only and grades 1-15 only.

2. Turn the table into a crosstab showing Gender by Grade with Gender the column heading.

3. Next to the crosstab insert a line chart with data points and grid lines displaying the same information.

4. Modify the line chart so there are two separate lines on the chart, one for female, one for male. Format the line chart as follows:

· Select Chart Format, Pivot tab. 

· In the Used Variables box ensure Grade or Level is on the X-Axis, Gender is on the Z-Axis, Total Employees is on the Y-AXIS

5. Insert a Legend to indicate which line is Male and Female.

6. Make any formatting changes required.

7. Next to the line chart insert a pie chart with data labels and percentages displaying Grade and Total Employees ONLY, do not include Gender. 

8. Insert a Legend and make any formatting changes you want.

9. We will NOT print this report as part of this exercise.  

· But you may want to use View>Page Layout to practice preparing the report for printing by moving the tables and charts, changing from portrait to landscape, changing margins, etc. 

10. Save document as Exercise7-5.rep.
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Exercise 8.1: Report Manager - Creating Multiple Reports with one Data Provider

Learning Objective: Manipulate data from a report without requerying the database.  

Estimated Time: 10 minutes

Scenario:  We need a report on Bargaining Unit.  After generating that report we realize we'd like to see some of the same data in different reports.

Directions:
1. Build a report to include Bargaining Unit Status (Position Data class), CCPO ID, Pay Plan, and Total Employees.

2. Select all encumbered positions and all CCPO Ids on the database

3. After creating the initial report, right-click the report tab and insert a new report. Ensure Report Manager is open.

· In the new report, hold the Ctrl key and select Bargaining Unit Status, CCPO ID, and Total Employees from the Report Manager Data tab. 

· Drag and drop these variables on to your new report.

· Format the report as you wish.

4. Right-click the report tab and insert a new report.

· In the new report, hold the Ctrl key and select CCPO ID, Pay Plan, and Total Employees from the Report Manager Data tab. 

· Drag and drop these variables on to your new report.

· Format the report as you wish.

5. We'd like to look at these reports for Goodfellow AFB only (CCPO 5A). Select Edit Data Provider button and modify the conditions to select only Goodfellow AFB .

6. Review all three reports.  They should all now show data for Goodfellow AFB only.

7. Modify the query to add Occupational Series, Gender, and Office Symbol and run the report.

· Do all the reports change?  _____________

· Which report(s) change? _______________

· What can you do to put the additional objects in the other reports? _________________________________

8. Save this document as Exercise8-1.rep. We will use this report in the next exercise.

Exercise 8.2: Report Manager - Using Multiple Data Providers

Learning Objective: In the previous document when we modified the conditions we changed the data in all the reports.  This time we want to apply separate conditions to each report in the same document.  In this exercise the report will not be created automatically, you'll have to drag and drop the objects for the Report Manager.

Estimated Time: 15 minutes

Scenario: This exercise continues the previous one.  We need to include a report in our document that uses different data and different conditions than the others.   

Directions:
1. Right-click the report tab and insert a new report.

2. Right-click the Variables folder in the Report Manager Data tab and choose New Data Provider from the pop-up menu.

3. The New Data Wizard will start.  Select "Build a new query on the universe currently in use" and press Finish.

4. Select CCPO ID, Health Plan, Health Plan Clear Text (both in Benefits folder), and Total Employees for all encumbered positions.

5. Run report.

6. The new objects display in the Data tab of the Report Manager but a report is NOT automatically made.

7. Select "By Data Provider" radio button on the Data tab to view objects by query.

· Open the Query 2 with Regional folder to see the objects.

· Drag and drop the new objects anywhere in the blank area to build your new report.

8. Click the Map tab in the Report Manager. 

· Ensure the Navigation radio button is selected.  

· Navigate to each report from this panel.

· Of course, you can navigate to all four reports by clicking the report tabs also

· Note that the previous three reports are still for Goodfellow AFB only.

· Click the Map tab's Structure radio button. 

· In this view the Report Manager displays the reports of the document and all components of the current report in structural view. 

9. Click the Edit Data Provider button and you are given a choice of Data Providers to edit.

10. Continue experimenting by creating another new report using another data provider or editing the two you currently have.

11.  Save this document as exercise8-2.rep.

Exercise 8.3: Report Manager - More Using Multiple Data Providers

Learning Objective: In this exercise the report will be created immediately. The objects will also appear as an additional query in the Report Manager.  This exerciset shows you a slightly different workflow from previous exercises.

Estimated Time: 10 minutes

Scenario: This exercise continues the previous one.  We need to include a report in our document that uses different data and different conditions that the others.   

Directions:
1. Right-click the report tab and insert a new report.

2. Select the Insert Table button. Move the cursor to the document and click where you want the table to display.

3. From the Insert New Table Wizard, select Access new data in different way. Select begin.

4. Select the HR universe, create a quick query, and run the report.

5. The report is displayed immediately and the objects display in the Report Manger Data Tab.

6. Now you have three different queries in one document.  

7. Rename each data provider to any name you like.

8. Continue experimenting by creating another new report using another data provider.

9. Save report as Exercise8-3.rep.
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Exercise 9.1: Master/Detail Reports

Learning Objective: How to create and modify Master/Detail reports.

Estimated Time: 15 minutes

Scenario: You have a major report with a lot of data and need to make it easier to read and navigate.

Directions:

1. Retrieve GunterMasterDetail.rep from the repository.

2. Click once in the CCPO ID Clear Text column data area to select it.

3. Click again in the yellow cell in the CCPO ID Clear Text column and drag the yellow cell out of the table and position it over the top left of the table. 

· Note the cursor changes to the "create section cursor" and the status bar displays Drop to move contents and create a section.

4. Release the mouse button.

5. Three things have happened:

· The CCPO ID Clear Text column is removed from the table and becomes the master cell.

· Data is now organized into separate tables for each CCPO ID sorted by the CCPO ID Clear Text.

· CCPO ID Clear Text has been added to the Map tab. 

6. The CCPO ID code column is not needed.  Delete it.

7. Go to the Report Manager Map tab. Ensure the Navigation radio button is selected.

8. Each CCPO ID Clear Text is listed.  You can quickly go to any CCPO ID Clear Text by clicking on it in the report map area.  Try it.

9. Now we will further organize the data so there is a separate table for each Pay Plan within each CCPO ID Clear Text.

10. Click in the Pay Plan column to select it.  Click again in the column and drag the cursor out of the table and position the Pay Plan cell between the top left of the table and the CCPO ID Clear Text and release the button.

11. Three things have happened:

· The Pay Plan column is removed from the table and becomes a master cell.

· The data is organized and sorted by Pay Plan within CCPO ID Clear Text. 

· Each CCPO ID Clear Text has a "+" sign next to it in the Map tab. 

12. Go to the Report Manager Map tab. Ensure the Navigation radio button is selected.

13. Click once on a "+" sign and it opens up to show the Pay Plans under that CCPO ID Clear Text. You can quickly go to any one by clicking on it. Try it.

14. Add a Count All and Count to the Occ Series column of any table.  Note they apply to every section.

15. Now that we’ve reviewed the report, we realize we really need it organized by CCPO ID Clear Text within Pay Plan!  We need to modify the report.

· Grab the Pay Plan master cell and drag it on top of the CCPO ID Clear Text master cell (actually cover the CCPO ID Clear Text cell).

· Look for the message on the Status Line to read, "Drop to swap contents". 

· Look for the Swap cursor (double arrows).

· Release the mouse button.  Now the data is reorganized.

16. Go to the Map tab.  

· Note that now Pay Plans are listed with a "+" sign next to them.  Open one of the Pay Plans to see the CCPO ID Clear Texts listed below.  

17. If we were going to print this report we would want each section to start on a new page.  To accomplish this:

· Right-click in the "white space" of a section.

· Select Format Section.

· Ensure the General tab is displayed in the Section Format window.

· Click Start on a new page.

18. Use Print Preview to see the result.  DO NOT PRINT.

You can remove the master cell in three ways. You will be prompted whether you also want to remove the section.

· Select the master cell.

· From the Edit menu, choose Delete.

· This will delete the data from your report.

· Select the master cell.

· Drag and drop it into the Data Tab of the Report Manager.

· This will delete the data from your report.

· Select the master cell.

· Drag and drop in back into the report.

· This will retain the data in the report.

19. Remove the master cells by dragging one back into the table and dragging the other to the Report Manager. In one case retain the section in your report; in the other remove the section also.  

Exercise 9.2: More Master/Detail Reports

Learning Objective: How to create and modify Master/Detail reports.

Estimated Time: 15 minutes

Scenario: You have a major report with a lot of data and need to make it easier to read and navigate.

Directions:

1. Build a report with CCPO ID, Pay Plan, and Total Employees for all encumbered records.

2. Make CCPO ID the master cell.  

3. Use Outline to compress this report.

· Select Outline from the View menu. An Outline bar will be added to the left side of your document.

· Practice opening and closing several of the CCPO ID tables using the arrows on the Outline bar.

· You can also open and close all the sections using the small '1' button on the bottom of the Outline bar.  Try it.

· To close Outline view, first ensure all the sections are opened, (HINT: use the '1' button above) then go to the View menu and select Outline view a second time. Close Outline view now.

4. Sum the employees by CCPO ID.

5. To place a grand total at the top of your report:

· Drag the sum in one of the tables to the top of the report (outside of any section and to the left or right of the report title). 

·  Before you drop it press the Ctrl key to copy.  

· Add a label in a freestanding cell. 

6. Sort the detail reports so the CCPO are in descending order.

7. Sort the Total Employees column in descending order.

8. Swap the Pay Plan with the CCPO master cell.

9. What is the total number of GMs employees?  What is the total number of GS employees? _____________________________________________________

10. Which base has the most AD Pay Plan employees?  WS Pay Plan? _____________________________________________________

11.  Add Gender to the query and create whatever Master/Detail report necessary to determine the number of:

Female, WG employees in 7N ______________________

Male GM employees in 9X _________________________

Male WS employees _____________________________

Female WS employees ___________________________

Male and Female AD employees ____________________
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Exercise 10.1: More Powerful Conditions - Using Wildcards

Learning Objective: How to use wildcards to build conditions.

Estimated Time: 10 minutes

Scenario:  You need to create a report about certain Position Titles.

Directions:

1. Build a report showing all the Position Titles at Wright-Patterson AFB. (9X)

2. Run and review the report.

· Look for errors such as Position Titles with incorrect spaces, misspelling, wrong case, etc.  These are errors in the database that could affect our conditions.  

3. Now modify the query using the % wildcard to look for all the supervisory Position Titles.

· Drag the Position Title object to the Condition panel. Select "Matches pattern", then "Type a new constant".  

· In the blank space created in the condition type SUPER%. 

4. Run the report.

5. How many supervisory positions are there? ______________________

6. Modify the condition by changing SUPER% to %SUPER% and rerun the report.

7. Now, how many supervisory positions are there? _______________________

8. Modify the condition to look for similar variations of:

· %SECRETARY%  

· %OFFICE AUTOMATION%  (try %O/A%)

· %ENGINEER%

9. In this exercise you modified the condition several times to select different Position Titles.  Try redoing this exercise, but using a prompted condition instead.

10. Save document as Exercise10-1.rep.

Exercise 10.2: More Powerful Conditions – Entering Constants

Learning Objective:  Learn how to enter a date as a constant in conditions.

Estimated Time: 15 minutes

Scenario:  You have been requested to provide a report on Adverse Information for all the bases on the database from 1990 through current date.

Directions:

1. Build a report to show:

· From Adverse Info class: Adverse Action NOAC, Adverse Action NOAC Clear Text, Date of Adverse Action. 

· From Employee Basic Info class: Name Employee and SSAN.

2. We want to see records with a Date of Adverse Action from 1 Jan 1990 through current actions. 
· Enter date format 01/01/90.  

3. Although we want encumbered positions it's not necessary to specify this.  Why? ______________________________________________________

     If a record has an ADV ACT it must be encumbered.

4. Right-click on Adverse Action NOAC Clear Text in the Results panel and sort in ascending order.

5. Run the report

6. Change report title, add cell with your name in it, add a cell with the date in it, and make any other formatting changes you like.

7. Answer the following questions. (Hint: When you use breaks and count all, use breaks first if you want to get subtotals.) 

What is the most common Adverse Action? How many? _____________________________________________

What is the least common Adverse Action? How many? _____________________________________________

How many Adverse Actions were there in 1991?

_____________________________________________

Are there any individuals with more than 3 Adverse Actions?  

______________________________________________

(HINT: Break on Employee Name, Count All on Adverse Actions, Sort on Totals.)

8. Save document as Exercise10-2.rep.
Exercise 10.3: More Powerful Conditions - Prompted Conditions

Learning Objective: Learn how to build a Prompted condition.

Estimated Time: 15 minutes

Scenario:  You need to build a report that will prompt the user to enter the CCPO Id(s) to run the query for.    

Directions:

1. Build a report showing Total Positions, Total Employees, Pay Plan, Grade or Level Clear Text, and CCPO ID Clear Text.

2. Drag CCPO ID (the code NOT the Clear Text) to the Conditions panel.  Select "In List", followed by "Type a new prompt".  

3. In the space created in your condition for you to type a prompt type the words "Which CCPO ID(s) do you want to see?".

4. Run the report. You will be prompted to enter one or more CCPO IDs.

5. Enter any of the CCPO IDs on the database.  THIS IS CASE SENSITIVE.

· Use the Values button on the prompt text box to display a list of available CCPO IDs. 

· You can pick off this list rather than type in values.

· This way you can avoid misspelling and lower case vs. higher case errors.

6. Use the Refresh button to rerun the report.  Run the report several times to ensure it works properly. 

7. Rewrite the report to prompt for Pay Plan instead of CCPO ID.

8. Run and test.

9. Rewrite the report to prompt for both CCPO ID and for Pay Plan.

10. Run and test.

11. Save document as Exercise10-3.rep.

Exercise 10.4: More Powerful Conditions - Multiple Conditions

Learning Objective: How to use multiple conditions.

Estimated Time: 10 minutes

Scenario: You've been asked to create a moderately complex report that requires the use of multiple conditions.

Directions:
1. Create a report to show all of the female WG employees and all of the male WS employees.

2. Include Total Employees, Grade or Level Clear Text, Pay Plan, and Sex.

3. Format the table as you desire.

4. How many male WS are there? ________________________________

5. How many female WG are there? ______________________________

6. Modify the condition (or create a new report) to show all the GM employees no matter what gender and all the female WS.

7. Format the table as you desire.

8. How many GM employees are there? ________________________________

9. How many female WS are there? ______________________________

10. Save document as Exercise10-4.rep.

Exercise 11.1: Report Enhancements: Creating Variables

Learning Objective: How to create local variables to make calculations on data.

Estimated Time: 15 minutes

Scenario:  We are conducting a survey of 12% of each base population and need to know how many surveys to have printed.

Directions:
1. Build and run a report showing Total Employees by CCPO ID for all the encumbered records and all bases on the database.

2. Insert a column on the right side of the table.

3. Right-click in the blank column to select it. 

4. From the pop-up menu, select Variables>Add.

5. Select the Definition tab.

· Type "12% of Population" in the Name box.

6. Select the Formula tab.

· Double-click Total Employees object in the list of variables.

· Double-click the multiply symbol "*" in the list of operators.

· Type 12 into the formula.

· Double-click the percent sign "%" in the list of operators.

· Click OK.

7. Note that your new variable is listed in the Variables window.

· Click the Insert button.

8. 12% of Total Employees should be displayed in the new column.

· Note that your new variable is also listed in the Report Manager panel.

9. Sum the Total Employees column and the 12% of Population column. 

10. Modify the variable use just created to be 15%, not 12%.  

· In the Data tab of the Report Manger, right-click the 12% of Population variable.  Select Edit Variable from the pop-up menu.

· In the Formula tab, change the percentage to 15%.

· In the Definition tab, change the name of the variable. 

· Click OK.

11. Review your report to ensure the change is made.

12. Make any formatting changes you like.

13. Save the report to your hard drive as Exercise11-1.rep. We will use this report in the next exercise.

Exercise 11.2: Report Enhancements: Using Formulas

Learning Objective: How to use formulas to make calculations on data.

Estimated Time: 10 minutes

Scenario:  The survey being conducted in the previous exercise will be printed and issued in a "rolling" fashion starting with the first base on the table and ending with the last.  We need to have a running total so we can plan for budgeting and let the print plan know how many surveys to print.

Directions:
1. Open the report Exercise11-1.rep.

2. Insert another column on the right of the table.

· Enter the column heading "Running Total".

3. Click inside the Running Total column.  

4. From the Data menu, choose Edit Formula.

· Double-click the equal sign "=" in the Operators list.

· In the functions box, open the All functions & aggregates folder.

· Scroll down and double-click RunningSum.

· In the Variables box double-click 15% of Population.

· Click OK.

5. Note that you now have a running total of the surveys that will be needed.

6. Ensure the last value in the newly created running total column is the same as the total of 15% of Population column.  

· Last value in running total column ______________________

· Total of 15% of Population column _____________________

7. Save the report to your hard drive as Exercise11-2.rep.

Exercise 11.3: Report Enhancements: Setting an Alerter

Learning Objective: How to use an alerter to highlight data that meets certain criteria.

Estimated Time: 15 minutes

Scenario:  Management needs to know how many of each type of disciplinary action each base has.  Also they would like to have it highlighted whenever there are more than 20 of any type of action.  Include a comment that reads "High Occurrence". 

Directions:

1. Build a report to include:

·  CCPO ID, Adverse Action NOAC, Adverse Action NOAC Clear Text, and Total Employees.

· Select encumbered records where Adverse Action NOAC is not null.

· Run report

2. Select the Total Employees column data area.

3. Select the Alerters button.

· Click the Add button on the Alerters window.

· On the Definition tab:

· Type "Over 20 Adverse Actions" in the Name box.  

· A description is optional.

· On the Conditions tab:

· Ensure Total Employees shows in the Variable to Compare box.

· In the Operator 1 list box select the greater than sign ">" from the drop down box.

· In the Value 1 box type 20.

· In the Operator 2 box select none.

· In the Result list box click the down arrow, select Format, Font tab, and select whatever Font, Font Style, Size and Color you prefer.  Red is the default for Alerters. 

· Click OK.

· Click OK in the Edit Alerters window.

4. You are now back in the Alerters box and the Alerted you just created is listed. Click OK.

5. All occurrences of more than 20 adverse actions are now highlighted using the Font, Font Style, Size and Color you selected.

6. To apply this alerter to another column:

· Select the Adverse Action NOAC Clear Text column data area.

· Click the Alerters button.

· Click the Over 20 Adverse Actions checkbox, then click OK.

· Now the alert also highlights this column.

· Add the alerter to the all the columns in the report.

7. To add a text alerter, insert a column on the right side of the table and give it the header, Comment.

8. Select the data area of the new column.

9. Click the Alerters button, then Add to create a new alerter.

· On the Definition tab: 

· Type "High Occurrence" in the Name box.

· On the Conditions tab:

· The Variable to Compare is blank because you started from a blank column.

· Select Total Employees from the Variable to Compare list box.

· Select the same Operator 1, Value 1, and Operator 2 as before.

· In the Results list box, select Text.

· In the Enter Your Text window type "High Occurrence" and click OK.

· Click OK in the Edit Alerters window.

10. You are now back in the Alerters box. Click OK.

11. You will now have a comment besides every occurrence greater than 20.

12. Save document as Exercise11-3.rep.

Exercise 11.4: Report Enhancements: Setting an Alerter and Grouping

AFPC IS REVISING THE CONDITIONS THIS EXERCISE REQUIRES.  

DO NOT ACCOMPLISH THIS EXERCISE AT THIS TIME.
Learning Objective: How use an alerter to highlight data that meets certain criteria.

Estimated Time: 15 minutes

Scenario:  You've been asked to provide an analysis of retirement eligibles for the USAFA and you need to highlight where more than 3 employees are eligible. 

Directions:

1. Build a report to Include:

·  Pay Plan, Office Symbol, and Total Employees.

2. Select:

· Pay Plans WG, WL, WS, and GS. 

· The USAFA (CCPO ID 6W).

· Encumbered positions.

· Ensure all employees eligible for Regular Retirement are selected.

· Use the predefined Regular Retirement conditions in the Retirement Group of Conditions.

· Ensure 55 and 30, or 62 and 5, or 60 and 20 are included.

· You will need to ensure the right logical operators (or/and) are used.    

3. Turn the table into a crosstab with Pay Plan as column header and Office Symbol as row header.

4. Add a sum.  

5. How many employees of each Pay Plan are eligible?

GS ___________
WG ___________

WL ___________
WS ___________

6. What Office Symbol has the most retirement eligible? ________ The next most? ____________

7. Combine the following office symbols and record the totals:

· All the office symbols that start with CC _____________

· All the office symbols that start with CE _____________

· All the office symbols that start with LG  _____________

8. Create an Alerter to highlight in bold red if 3 or more employees are eligible in any Pay Plan within any Office Symbol. 

9. Insert a pie chart and show what percentages of eligibles are in each Pay Plan.

10. Make any other formatting change you like.

11. Save document to your hard drive as Exercise11-4.rep.

Exercise 11.5: Report Enhancements: Grouping Related Data and determining variances

Learning Objective: How to bring together related values and calculate the variance between two values. Under the Basic Queries and Condition, see BusinessOjects Help document for more info on the Age object.

Estimated Time: 15 minutes

Scenario:  The new Goodfellow AFB wing commander needs a report analyzing base population by age grouping and gender.   

Directions:
1. Build a report to include:

·  Age in Years (a detail object under Birth Date in the Employee Basic Info class), Gender and Total Employees.

2. Select Goodfellow AFB (5A) encumbered positions.

3. Run report.

4. Insert a Sum on the Total Employees column. 

5. Group ages by gender into: (HINT: Sort by age and do both genders at once.)

·  Age 29 and below

·  Age 30 to 45

·  Age 46 to 55

·  Age 56 to 65, Age 66 and up.
· (We have specifically chosen these group names so they will sort right.  You need to consider your naming convention when grouping data.)

6. Create a Master/Detail report based on Gender.

7. How many male employees?   _____________.

8. How many female employees?  ____________.

9. How many female employees between ages 56 and 65?__________.

10. How many male employees between ages 30 and 45?____________.

11. Determine the difference (variance) between Age 29 and below and Age 30 to 45.  

· What is the difference? ______________

12. Determine the difference (variance) between Age 46 to 55 and Age 56 to 65.

· What is the difference? ______________

13. Save document to your hard drive as Exercise11-5.rep.

Exercise 12.1: Sharing Reports by Sending Documents 

Learning Objective: How to send an existing document saved to your hard drive to a BusinessObjects user.

Estimated Time: 10 minutes

Scenario:  You need to share a report with an existing BusinessObjects user.

Directions:

1. Select File|Send to|Users. The Send window opens.

2. Ensure the Domain drop down text box displays DocBCA.

· The DocBCA domain is for sending documents.

· The CorpDoc domain is used by AFPC to save documents.

· The Doc_XX domain is used for the CPF to save documents.

 (where XX is the CCPO ID. The school is an exception. In our case it is Doc_Max) 

3. Click the To button to open the list of users and groups you can send a document to.

4. In the left-hand panel select the student account of a student sitting next to you and double-click or click Add. 

5. The selected user is displayed in the Document Recipients list. Click OK.

6. You are now back at the Send window.  

7. Click Browse and select the document to send and double-click or click Add.  These are documents you have saved on your hard drive in the UserDocs folder.

8. Click OK to send the documents.  

9. You will receive a message confirming that the export was successful. Click OK to remove the message.

Retrieving Documents Sent by Users
1. Log in again.

2. Cancel New Report Wizard if it starts.

3. Click File>Retrieve From and select Users.

4. The Retrieve window is displayed.

5. Select the documents you want to retrieve and click Retrieve.

Exercise 12.2: Sharing Reports by Publishing Documents

Learning Objective: How to publish an existing document to the repository.  AFPC will publish documents to the CorpDoc document domain.  The CPF will publish documents to the Doc_XX domain (where XX is the CCPO ID, in our case it is Doc_Max).   

This exercise will be demonstrated only by the instructor and not accomplished by students in order to prevent filling up the Doc_Max domain with excess documents.

Estimated Time: 5 minutes

Scenario: You need to make a document available to all the users who have access to Doc_XX domain.

Directions:
1. Select File|Publish to|Corporate Documents.

2. Change the domain to Doc_Max.

3. The Send to box shows the user group(s) that will be able to view and retrieve the published documents.

4. Click Browse and select the document to publish and double-click or click Add.  Note these are documents you have saved on your hard drive in the UserDocs folder.

5. Click CANCEL to cancel sending the documents. If you were really publishing these documents you would click OK.

6. You would receive the message "Export was successful".

Exercise 12.3: Sharing Reports by Saving them as HTML

Learning Objective: How to save an existing document as HTML in order to share reports with non-BusinessObjects users.

Estimated Time: 10 minutes

Scenario:  You need to give a manager access to a report you created in BusinessObjects.

Directions: 
1. Retrieve Goodf by Pay Plan and Sex.rep from the repository.

2. Duplicate the report twice.

· Name the first report Table, the second report Bar, and the third report Pie.

3. In the Bar report, select the table, right-click to get the pop-up menu, and select Turn to Chart.

4. Turn the table into a 3D Column with grid lines.

5. In the Pie report, select the table, right-click to get the pop-up menu, and select Turn to Chart.

6. Turn the table into a Pie chart with labels and percentages.

7. Make any formatting changes you like in each reports

8. Click File>Save As HTML.

7. Accept the default filename and click Save.  

· The filename ends in htm. 

· The default folder is the UserDocs folder where you have been saving your documents on your hard drive.

9. The HTML Options window appears.

· In the Save area, you can choose which reports in your documents to save as HTML files.  Choose All Reports in Document.

· Ensure the All in one page button option is selected so the users can view the reports as one HTML page.

· If you want to allow users to download this document, check BusinessObjects document check box.

· Click OK.

10. If you were at your base you would follow local procedures for delivering the HTML file to your colleagues (possibly by copying it your Intranet).

Viewing the HTML File

1. Right-click the Start button on the Windows task bar and choose Explore to find the file you just saved under \Program Files\Business Objects\BusinessObjects 5.0\UserDocs.

2. Look for the htm file extension.

3. Double-click on the file to open it in you web browser.

4. When done viewing the file select File>Close.
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Exercise 13.1: Using Personal Data Files 

Learning Objective: How to use Excel spreadsheet with BusinessObjects

Estimated Time: 10 minutes

Scenario:  The HR database may not have variables for some data you need to track.  In this scenario you use an Excel spreadsheet to track this data.  You need a report that will show your spreadsheet with a report from the HR universe.  

Directions:

1. Build a report showing:

· CCPO ID, Gender, and Average Age (Age measure object).

2. Select all bases and encumbered positions.

3. Run the report.

4. Click the Insert table button and draw a rectangle where you want the new block.  When you release the mouse button, the New Table Wizard appears.

· Select Access new data in a different way and click Begin.

· Click Others radio button and select Personal data files and click Finish.

· In the Access Personal Data dialog box select Microsoft Excel files (*.xls) and browse to file location. The instructor will give you the filename and location.

Filename___________________________________________

Location____________________________________________

· Select the file and click the Open button. The Access Personal Data Window will be displayed again.

· Click First Row Contains Column Names, and click Run.

· The spreadsheet will be inserted into your report as a table.

· Note the variables are added to the Data tab of the Report Manager. 

5. Click the By Data Provider radio button at the bottom of the Report Manager Data tab. 

· When you have more than one Data Provider, it can be helpful to organize the data by Data Provider.

6. You also need to include some data from a text file in a separate report in the same document.  

· Right-click the report tab and insert a new report.

7. Click the Insert table button and draw a rectangle where you want the new block.  When you release the mouse button the New Table Wizard appears.

· Select Access new data in a different way and click Begin.

· Click Others radio button and select Personal data files and click Finish.

· In the format box select Text files (*.asc, *.prn, *.txt, *.csv) and browse to file location. The instructor will give you the filename and location.

· Filename______________________________________________

· Location_______________________________________________

· Click First Row Contains Column Names, and  Run.

· The text file will be inserted into your report as a table.

8. Save document to your hard drive as Exercise13-1.rep.

Exercise 13.2: Including Graphic and Other Data Objects

Learning Objective: How to insert embedded and linked data and pictures. BusinessObjects supports a Windows feature that enables you to use data, text and pictures in different applications. This feature is Object Linking and Embedding 2 (OLE 2). OLE 2 objects are created from files (text, ASCII, spreadsheet, bitmap) and are linked or embedded inside files in other applications. For example, OLE 2 enables you to embed a bitmap image in a BusinessObjects report.

Linking vs. Embedding

The main differences between linked and embedded objects are where you store the data and how you update the data after you place it in the destination file.

When an object is linked, information is updated only if you modify the source file. Linked data is stored in the source file. The destination file stores only the location of the source file and displays a representation of the linked data. Use linked objects if file size is a consideration.

When an object is embedded, information in the destination file doesn't change if you modify the source file. Embedded objects become part of the destination file and, once inserted, are no longer parts of the source file. Double-click the embedded object to open it in the source program.

Estimated Time: 10 minutes

Scenario:  You want to link an Excel spreadsheet and embed a Microsoft clip art picture in a BusinessObjects report.

Directions:
1. Use any report you've already created or create a quick report.

2. Do either one of the following:

· Create and select a freestanding cell and then select Insert>Object.

· Select Insert>Object first, your cursor will change to Insert Cell image with OLE2, draw a box where the object will be inserted. 

3. The Insert Object window will appear.

· Select the Create New radio button.

· Select Microsoft Clip Gallery from the Object Type List and click OK.

· After the Microsoft Clip Gallery opens select an image and click insert icon or the OK button. 

4. You will be returned to BusinessObjects and the image will be embedded.

5. Next we will link to an Excel spreadsheet.

6. Repeat step 2.

7. You are now viewing the Insert Object window.

8. Select Create from File. Check the box to Link to the file.

9. Browse to the folder and file your instructor identifies.

File name_____________________________________

File location___________________________________

10. Select the file and click Open.

11. You will be returned to the BusinessObjects Insert Object window.  Click OK.

12. You will be returned to BusinessObjects and the file will be inserted.

13. Ensure you can modify the Excel file by double-clicking on it. 

Exercise 14.1: Exporting Data from BusinessObjects - Copying and Pasting to another application 

Learning Objective: How to cut and paste data or whole reports into Microsoft Word.

Estimated Time: 10 minutes

Scenario:  You want to cut and paste a BusinessObjects report into Word to share the report with users who don't have BusinessObjects.  

Directions:

1. Use any report you saved to your hard drive or build a quick report.

2. Choose Copy All from the Edit menu.

3. Open Microsoft Word.

4. From the Edit menu, choose Paste Special.

5. Paste the table using each of the options:

· Formatted Text (RTF)

· Unformatted Text

· Picture

· Bitmap.

6. How did the table paste differently using these different formats?

______________________________________________

RTF - Table format retained.  Can be modified.

Unformatted - Lose table format. Can be modified.

Picture and Bitmap - Table format retained.  Cannot modify.
______________________________________________

7. Close Microsoft Word and return to BusinessObjects.

Exercise 14.2: Exporting Data from BusinessObjects - More Copying and Pasting to another application 

Learning Objective: How to cut and paste data or whole reports into Microsoft Excel.

Estimated Time: 10 minutes

Scenario:  You have another report in BusinessObjects that you need to share with non-BusinessObjects users.

Directions:
1. Create a crosstab showing the Total Employees, by Gender, for all the CCPO Ids in the database; include encumbered positions. 

· (HINT: Total employees should be right-most column.  Make Gender the column header.)

2. After you create the crosstab choose Copy All from the Edit menu.

3. Open Microsoft Excel.

4. From the Edit menu, choose Paste Special.

5. Paste the crosstab into Excel using each of the options:

· Picture (Enhanced Metafile)

· Bitmap

· Unicode Text

· Text

· What are the differences in these options? 

_____________________________________________________

Some options allow you to edit the data, some do not.


· If you have time, turn the crosstab into a chart and paste the chart into Word. 

· (HINT:  Must be pasted as an image.)

· Return to BusinessObjects.

· Save the file to your hard drive as Exercise14.2.rep. 

· You will use this file in the next exercise.

Exercise 14.3: Exporting Data from BusinessObjects - Saving data as another format

Learning Objective: How to export BusinessObjects data to Microsoft Excel.  In the last exercise we cut and paste the data into Excel.  In this exercise we will export the data from BusinessObjects to Excel format.  Then the recipient can read it in as an Excel file.

Estimated Time: 10 minutes

Scenario:  You need to share a BusinessObjects report with someone who does not have BusinessObjects.  The person does have Excel and needs to manipulate the data in Excel. The report is the crosstab created in the previous exercise.

Directions:

1. Open the report you created in the previous exercise.

2. If your report is a chart, turn it to a crosstab by right-clicking on it and selecting Turn to crosstab from the pop-up menu.

3. Click the View Data command on the Data menu.

4. In Data Providers box, click the data provider containing the data you want to export. 

5. Click Export.

6. Select the format you want to export to.

· In this case select Microsoft Excel files (*.xls)

· Browse to file location.  (Use C:\temp)

7. Select the filename you want to save the file to or use the default.   Write the filename here. ________________________________________________

8. Click Save. 

9. This will return you to the "Export to External Format" dialog box.   Click OK.

10. You should see the message "Export Done!"

11. Open Excel and open the file you just saved.
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Exercise 15.1: Simple Drilling 

Learning Objective: How to create a document for use in drill mode to analyze different levels of data within a document.  

Estimated Time: 15 minutes

Scenario:  You need to create a report showing base population of each base that can be analyzed at different levels of detail. 

Directions:

.

1. Build a report showing CCPO ID and Total Employees.

2. Select encumbered records

3. In the Query panel click the Scope of Analysis button.

4. Click the By Hierarchy radio button.

· In the MAJCOM Class, select PATCOB Description and Gender.

· Click the OK button. 

5. Run the report.

6. Select the drill button.

· A new report with a magnifying glass on the tab is created for you to drill on.

· A Sum has been added to the Total Employees column of this new report.

7. Use this drillable report to answer the following questions. Remember you can use the Map tab to navigate.

8. How many Blue Collar workers are in CCPO ID 41? _____________________________________

9. How many Professional employees are in CCPO ID 6W?  _________________________________________

10. How many Female and Male Clerical employees are in CCPO ID 7N?   ____________________________________________________     

11.  How many Female and Male Technical employees are in CCPO ID 9B?   

      _____________________________________________________

12. How many Male and Female employees in CCPO ID 8T?  _____________________________________________________

13. How many employees are in each PATCOB in CCPO ID 9X? ________________________________________________________________________________________________________________________________________________________________________

14. What PATCOB has the most employees at CCPO ID 5A? ________________________________________________________

15. Continue drilling to explore this report.

Exercise 15.2: More Simple Drilling 

Learning Objective: How to modify an existing document to use drill mode to analyze different levels of data within a document.  In this exercise we don't set the Scope of Analysis until AFTER we run the report using the pop-up menu.

Estimated Time: 10 minutes

Scenario:  You need a report that can be analyzed at different levels of detail showing because it will be used for several different purposes. 

Directions:

1. Build a report to include Total Employees, Gender, and CCPO ID for all encumbered records on the database.

2. Do not set the Scope of Analysis in the Query Panel.

· We are pretending we forgot to set the Scope of Analysis in the Query Panel. When that happens, we can either go back to the Query Panel or use the pop-up menu.

· In this exercise we will use the pop-up menu.

3. Run the report.   

4. Click the Drill button.

5. Right-click in the CCPO ID column, a pop-up menu will appear.  

· Drill down, Drill up, and Drill by are grayed out. 

· This is because you did not originally create this report to be drillable.  Therefore we must correct this before we can drill.

· Select Scope of Analysis from the pop-up menu.

· Select the Class radio button and open all the folders. 

· Select Race National Origin Clear Text and MAJCOM from the list of items you can drill on. Click OK. 

· You may have to wait a minute while BusinessObjects requeries the database and retrieves this new data.

6. Now the report it drillable.

7. Create a Master/Detail report with Gender as the Master Cell.  What happens?

8. ______________________________________________

Gender displays in the drill toolbar.

9. Insert a Drill Filter with a label identifying what it is.

10. Drill this report any way you like to answer questions about this data. Some suggested questions to get you started are:

11. What is the breakdown of females by Race National Origin for CCPO 41?

______________________________________________

12. How many MAJCOMs at CCPO 5A, at CCPO 9X?

______________________________________________

13. What is the breakdown by gender in each of the above MAJCOMs?

______________________________________________

Exercise 15.3: More Simple Drilling 

Learning Objective: More practice on creating a document for use with drill mode to analyze different levels of data within a document.  

Estimated Time: 10 minutes

Scenario:  You need to create a report showing adverse action data at both a high level and to be able to "drill down" to lower levels. 

Directions:
1. Build a report showing Adverse Action NOAC and Total Employees for all encumbered records where Adverse Action NOAC is not null and  date of action is greater than or equal to 1/1/99.

2. In the query panel select the Scope of Analysis button.

3. Select any objects you like to drill on. Click Ok.

4. Run the report.

5. Select the drill button and a new report tab will be created for you to drill on.

6. Drill this report any way you like to answer questions about this data.
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Exercise 16.1: Slice and Dice Panel

Learning Objective: Practice using the Slice and Dice Panel.

Estimated Time: 10 minutes

Scenario:  You are at the Air Staff and require a report on Pope AFB, USAFA, and Spangdalhlem AFB.    

Directions:
1. Build a report to include:

·  Total Positions, Position Title, CCPO ID, CCPO ID Clear Text, and Pay Plan. 

2. Select encumbered positions at:

·  Pope AFB (5T), USAFA (6W), and Spangdalhlem AFB (7N).  

3. Run the report.

4. Make any formatting changes you want.

5. Open the Slice and Dice Panel.

6. Ensure the Available Variables Panel is showing.  

· If not, use the Show/Hide Available Variables button to display it.

7. Remove the Pay Plan column from the report by dragging it to the Available Variables Panel.  Click on "Apply".

8. To see the result, close, move, or minimize the Slice and Dice Panel. 

· To close the panel, click the close-window button (X) at the top right of the window.

· To move the panel,  "grab" the Slice and Dice Panel's blue title bar and just drag it out of the way. 

9. Use the Slice and Dice Panel to change the way you report is sorted.  Choose any object you like to resort.  Click Apply and view the modified report.  

10. Use the Slice and Dice Panel to insert a break on CCPO ID. Click Apply and view the report. 

11. Use the Slice and Dice Panel to insert a filter on Position Title to show all the positions that start with the word "Supervisory".  (HINT:  Select multiple contiguous titles with shift-click.)

12. Use the Slice and Dice Panel to add a Sum to Total Positions and a Count to Position Title.
13. Save this report as Exercise16-1.rep.  We will use this report in the next exercise.

Exercise 16.2: More Slice and Dice Panel

Learning Objective: Converting a table to a crosstab and a crosstab to a chart.  

Estimated Time: 10 minutes

Scenario:  We need to try a couple different ways to display the data to determine which will present it most clearly.  We will use the report created in the previous exercise to create a new report to display CCPO ID, Pay Plan, and Total Positions. 

Directions:
1. Right-click the report tab on the document you created in the last exercise and select Insert Report.

2. From the Data tab of the Report Manager select CCPO ID, Pay Plan, and Total Positions and drag these objects to create a new report. (HINT: Use ctrl-click to select multiple noncontiguous objects.)

3. Open the Slice and Dice Panel.

· Drag the CCPO ID object above the dotted line.  

· Click Apply and view the new crosstab.

4. From the Slice and Dice Panel right-click the tab at the bottom of the Panel.  

· Select Turn to Chart. 

· Select any 3D Column Chart. 

· Select Apply and view the chart.

5. From the Slice and Dice Panel apply a filter to the Chart you just created to show only WG, WS, and WL Pay Plans. 

·  Click Apply and view the modified chart.

6. Make any format changes you want.

7. Save this report as Exercise16-2.rep.  You can use this report in the next exercise.

Exercise 16.3: More Slice and Dice Panel

Learning Objective: Creating a Master/Detail report from a table. We also need to show the top 10 positions at these bases by number of positions.

Estimated Time:10 minutes

Scenario:  We need to modify the previous report to view the data more easily. We will create a Master/Detail report based on CCPO ID. 

Directions:
1. Open Execise16-2.rep.

2. Right-click the report tab on the document you created in the last exercise and select Insert Report.

3. From the Data tab of the Report Manager select CCPO ID, Position Title, and Total Positions and drag these objects to create a new report.

4. Open the Slice and Dice Panel 

· Ensure the Section panel is displayed. (Use the Show/Hide Section button to display the Section Panel.)

· Create a Master/Detail Report based on CCPO ID by dragging the CCPO ID object from the Block Structure Panel to the Section Panel.

· Click Apply and view the modified report.

5. We want to know what are the 10 most common positions at each of these bases.  

6. From the Slice and Dice Panel:

· Select the Position Title object and then the Ranking button.

· Ensure Total Positions is displayed in the Based on box.

· Select the Top check box and enter 10 in the box to the right.

· Select Display Subtotals and Display Percentages.

· Select OK, Apply, and view report.

Can you use this data to analyze the type of work done at each of these bases? Are there any significant differences in the top ten positions among these bases?  What are they?  

______________________________________________________________

Redo the above report selecting different bases and different rankings (for example the top or bottom 3) and compare the results.
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Exercise 17.1: Templates and Standard Report Styles

Learning Objective: How to apply an existing template to your report and how to create and apply a new template for your reports.

Estimated Time: 10 minutes

Scenario:   You want to apply one of the existing BusinessObjects templates to your report and to create and apply a new template that reflects your requirements to the standard templates that come with the BusinessObjects software. 

Directions:
1. Create a new report showing the number of employees at each CCPO ID in the default table format. (Or use an existing report)

2. To apply an existing template to this report:

· Choose Format|Report|Apply Template.

· Choose the Pie Chart, select Apply, and OK.

· Continue experimenting until you find a template you like.

3. In order to create a new template you must first create a report to use as a template.

4. Build a new report that will be used as a template. You may want to:

· Insert a cell for the user to put his/her name.

· Modify the standard title cell to prompt for a new title.

· Insert a clip art picture, change colors and font sizes, etc.

5. Make sure the report you want to use as a template is active if you have multiple reports in one document.

6. Choose Save As from the File menu.

7. Click the Save as type box drop down arrow, and then click BusinessObjects Template (*ret).
8. The BusinessObjects template folder location will appear in the file name box.  

· If you want the template to be available in the New Report Wizard, you must save it in the Template folder in the BusinessObjects folder.  Leave this unchanged.

9. Clear the file name box and type the file name mytemplate. Click Save.  

10. To use this template:

· Run the new report wizard.

· At the first wizard screen choose Select a Template.

· Find the template and select it.

11. Continue creating a report run it to view using the new template. 

Exercise 17.2: More Templates and Standard Report Styles

Learning Objective: Customize and apply standard report styles to a report.

Estimated Time: 10 minutes

Scenario:   You want to change the heading color and number formatting for all standard reports. 

Warning:  Standard Report styles are saved in a file named DEFAULT.RET.  Before we start this exercise, check with your instructor to ensure the original DEFAULT.RET has been renamed and saved so we can recover the original BusinessObjects configuration for the next class. 

Directions:

1. Select Tools and then Standard Report Styles.

2. From the Report Components panel, highlight Tables. 

· Under the Border tab, select Box from Presets, and Red from Colors. 

3. Open the Tables component.

4. Under the opened Tables component, select Header.

· Choose the Shading tab, click in the Foreground color box to display the color palette. Choose any color you like.

5. Under the opened Tables component, select Body. 

· From the Settings tabs, choose the Number Tab, Category item Number, and whatever Format you prefer. 

· In all reports that use this Standard Report the new default for number will be this new Format.

6. Click Ok and the changes will apply to all future reports. 

· If you currently have a report open, you must click Apply and then Ok to apply the changes to the current report.

7. Highlight the Tables component. 

·  Make any more changes you like to the under the General, Page Layout, Border, and Shading tabs. 

8. Under the Tables component, highlight Header.

·  Make any more changes you like under the Number, Alignment, Font, Border, and Shading tabs.

9. Repeat the above step for the Body.

10. Create a new report and verify that both the heading color and the number format have changed.

11. Now go back to the Standard Report Styles and modify the Standard Report Style for the Crosstab.

12. When you are finished with this exercise, check with your instructor to ensure the original DEFAULT.RET replaces the one you just modified. 

Exercise 20.1: Page and Report Layout

Learning Objective: Prepare a report for display or printing.

Estimated Time: 10 minutes

Scenario:    We need to ensure a report will display tables and charts properly as the contents change from time to time.  Also, we wish to hide any section with less than a certain number of employees. 

Directions:

1. Build a report to show:
· CCPO ID, Age in Years, and Total Employees for encumbered records.
· Age in Years is under Birth Date in the Employee Basic Information class.
2. Include a condition that will prompt the user for the high end and the low end of a range of ages. 
· For example, it should be possible for the user to enter ages so that at one time we can run the report for all employees 65 to 80, the next time we can run the report for all employees 15 to 21, etc.
3. Run the report for all employees 65 to 80.
4. Turn the report into a Master/Detail report with the CCPO ID as the master cell.
5. Sum the TOTAL EMPLOYEES column.  Outside the sections, add a block and enter your name and a block for your title. 
· You may need to turn on section delimiters to see where the sections are.
· Align the blocks any way you wish.  Make any other formatting changes you wish. 
6. Insert a 3-D column chart beneath the table.  
· Ensure that the chart's position relative to the table will remain constant for each subsequent run of the report. Keep the chart beneath the table.
7. Refresh the report and run it for a different age range. (For example 30 to 65).  Ensure the charts display properly.
8. We do not want to see any section with less than 1000 employees.  Hide these sections. After you make this change, edit it to reflect 1500 employees.  
· You may have to modify these numbers in order to make this work for you, since the age ranges you entered earlier will determine how many employees are in your report. 
9. Refresh the report a few times with different age ranges to ensure it is working properly.
10. Save your document as Exercise20-1.rep.
11. You can use this report in the next exercise.
Exercise 20.2: More Page and Report Layout

Learning Objective: Prepare a report for display or printing.

Estimated Time: 10 minutes

Scenario:    We need to ensure that our report displays certain information on each page and that each new CPF's data starts on a new page.  We also want to add page numbers and a date to indicate the last time the data was refreshed. Finally, since this report contains a lot of data we don't always want to see, we will display it in outline view.

Directions:

1. Use the report you created in Exercise 20.1. Ensure you are not hiding any sections, tables, etc.

2. Use Print Preview and/or Page Layout to see how the report would print now and as you make the following changes.

3. Ensure the Report Title and the cells with your name and title appear on every page.

4. Ensure the report fits properly on the page.

5. Ensure each new section starts on a new page.

6. Insert the date last refreshed in the header of each page 

7. Insert the page number in the footer of each page.

8. Change to Outline view. 

9. Fold the report so that each CCPO ID is display but the data associated with each are not visible.

10. Use the Map Tab and the Outline bar, and the button at the bottom of the Outline bar to view selected CCPO ID's records.

11. Save this document as Exercise20-2.rep.
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